Wlan0 disappeared while following Arch Linux install video

Hello all,

I followed the Arch Linux installation video to a tee. Everything was great until it came to the installation of the optional CPU packages. I have Intel so I typed out the correct pacman command but it failed to find the repositories. I thought that was weird because everything up until this point was working perfectly. So I did what everyone does and I tried it again, same result. I then decided to check my internet status by pinging Google and it did not work like it did previously in the tutorial video. I then checked on my network adaptors and to my surprise the wlan0 I had used this whole time was not listed, along with my ethernet(which I was not using but was there previously).

I did the classic reboot to see if it fixes the issue but alas it did not.

I am here to ask for help on what I can do to resolve the issue. If I need to start the installation process again at what point should I start from and in general just find out what happened so I know for future reference.

In case you need to know I am very new to Linux in general only dabbling with self installers in the past and I thought I would give this a go. I am not frustrated just want to learn from any mistakes I have made.

Any help will be greatly appreciated or questions I need to answer will be promptly replied to(as long as I am awake that is).

Thank you for taking the time to read this novel.


UPDATE: I was poking around and found out a few things that might help find out why this is happening.

I did a search for the Intel wifi drivers on my system and this is what I found.

Maybe I am wrong but it looks like I have the correct drivers.

Thanks again.



I had similar issues after installing on a Lenovo laptop.

After some troubleshooting I suspect that NetworkManager doesn´t play nice with my setup.

Most likely I jumped through I few unnecessary hoops to get it working and this probably far from the optimal solution. Here are some of the steps I remember taking and I stopped once I got it working:
[as root, with ethernet connected]

pacman -S linux-firmware
pacman -S iwd
pacman -S dhcpcd

systemctl disable NetworkManager
systemctl enable iwd
systemctl enable dhcpcd

There were a few reboots and some fiddling with iwctl and wifi-menu along the way…

Good Luck and just hang in there!


hi, i am a newbie to linux. i am writting to ask for help in installing archlinux in my Lenovo Laptop K2450, Intel i5.

i used to go with ubuntu, but it is full of error (chrome wont open, can’t login, etc.)

i tried installing linuxmint, which works on my work / office PC, but can’t seem to boot on my laptop.

i am now experiencing error in the same spot, when installing GPU. it kept showing these errors

i dont know what to do or where to begin with trouble shooting the problem.

i have no prior programming background, i use linux because i cant afford windows or macs. please help?

thank you in advance.


Same situation here. Everything went great without an issue, but the following command failed.

pacman -S intel-ucode

After that, I noticed the lost internet connection and found out that wlan0 is missing.
Does someone know the reason for that? What went wrong? Caused the intel-ucode command this issue or maybe the wlan0 was lost after the reboot (after GRUB installing)?

It seems that I’m not alone with this problem. Jay, can you please say something about that?
How to find out what is wrong and how to fix it? Please be so kind and help.

Thanks a lot!