USB Type C Docking Stations - My issues

Hey first post here! But Jay’s latest video (USB Type C Docking Stations - Getting Started Primer - YouTube) made me want to ask a few questions and vent my frustration.

I currently use the Lenovo Thinkpad 2 Extreme Gen 2 with (currently) debian 11. The current dock that I am using is the Lenovo DUD9011D1 (ThinkPad Hybrid USB-C with USB-A Dock - Overview and Service Parts - Lenovo Support CA) and, to say it nicely, it sucks. It is the reason why I went from Pop OS → Arch → Ubuntu → Debian. After a while, every distribution just breaks with it and I do not know why. Long story short, when plugging in the USB-C, the only thing that works is the usb hub. No ethernet and no displays (using DisplayLink kill me). Everything only works (besides charging) when plugging into the USB 3.0 port on the laptop. And I’ll be honest, I really enjoy having the ability to charge my laptop with the dock. So this is an on going frustration.

Jay mentioned his dock which I took a look at (and for some reason Thunderbolt isn’t explicitly stated which concerns me but I trust Jay). I am also looking at this dock (40AN0135US - can’t put another link cuz new user). Any thoughts on these?

I also want to ask if anyone has been having issues with thunderbolt docks when disabling Nvidia graphics (I use bumblebee). I disable them because I enjoy the extended, cooler and quitter laptop and because I really don’t need it. But I am wondering if my displays will work - (long story short, the hdmi output on the laptop goes directly through the NVIDIA gpu which stops it from working. And because I used display link on my other dock. I don’t know if disabling the dedicated Nvidia GPU will prevent from a display signal being sent to the display). Any advice would be greatly appreciated!

Welcome to LLTV @databending !!

I can’t speak to Thunderbolt on *Nix distro’s, but, my work-issued Laptop is a Lenovo X1 Extreme and I bought a Lenovo Dock to go with it. I had similar issues on WinDoze; Nic card stopped working, Video erratic, and some other really odd things. Turned out, the Lenovo Firmware Update Software wasn’t installed / enabled and I was a couple revisions behind. Once I installed it and got things updated, all my anomalies disappeared.

I’m not saying that’s what your issue is, but, its certainly something to consider / look at.

Thanks for the help! Sadly everything works well on windows (another story of manufactures only optimizing for windows) and I am running the latest of everything. Even updated the dock and still same issues

1 Like

Have you tried turning the computer off, plugging in the dock, and then turning the computer back on? I have to do that the first time I use my Lenovo dock after installing a new Linux OS.

For some reason, the automatic hardware recognition on my Leveno P73 doesn’t work if I plug the laptop into the dock if it is running. Once it has been recognized I can usually plug and unplug the dock while the laptop is running. Every once in a while the mouse disappears and I have to reboot.

Funny enough, that issue actually happened when I was running arch. Now that’s not a fix, but I had to switch away from arch anyways because DisplayLink was causing artifacts. What lenovo dock are you using btw? In the end, I am pretty set on buying a new thunderbolt dock anyways.

I have

1 Like

I have found USB-C docking stations a minefield - found your post, re-watched Jay’s docking station video you mentioned (realised I had already seen it and forgotten the advice) and now sorted my issues with my Lenovo L480 laptop and 2x HDMI displays.

I first inadvertently bought a Lenovo USB-C 40AF0135UK dock for £85 on eBay, which did not work at all even though I installed the proprietary Displaylink package onto PoPOS 21.04. Very disappointed I had not listened to Jay. I tested it with Windows 10 and it worked fine streaming 4K to two displays - so will confidently resell on eBay stating clearly it is only suitable for Windows.

Second attempt (remembering Jay’s advice - stick to standards) was a Lenovo Thunderbolt 3 40AC dock on eBay for £73. Had issues (coming to that in a sec) and thought I had bought another failed dock for Linux. I did not realise the USB-C port on my Lenovo L480 laptop that is labelled for charging is NOT a Thunderbolt port. The documention for the L480 don’t make it at all clear. There is a second port that does not even look like USB-C located closer to the front of the laptop, which is intended for the physical dock connection, which takes the Thunderbolt 3 connector fine, and BOOM the display ports on the dock came to life.

Thunderbolt provides (by design) DisplayPort, which is supported by the hardware. No drivers. As Jay said in his docks video - stick to standards to avoid problems.

Thanks to Jay for the good advice, I should have listened. Thanks to the poster of a forum (I cannot remember which) about the L480 Thunderbolt port being separate to and located in front of the USB-C charging port.

I have found that PopOS/Ubuntu is not happy about me disconnecting displays and reconnecting them. It doesn’t always come back and I get a blank display, so I have to reboot. Odd.