USB Drive Will Not Mount Using fstab

OS: Debian 10 Buster

Output from blkid:

/dev/sde1: LABEL="WD 2TB" UUID="e1eaaf80-c729-414b-89c3-5aa64a51401d" TYPE="ext4" PARTUUID="707d72fa-41d7-43f6-91e0-b1f65053fd59"

Line I added to fstab:

UUID=e1eaaf80-c729-414b-89c3-5aa64a51401d /media/usb0 ext4 default 0 2

When I run sudo mount -a I get the following error: "mount: /media/usb0: wrong fs type, bad option, bad superblock on /dev/sde1, missing codepage or helper program, or other error."

What I have tried:
The thing is, before I did any of that, I used sudo mount /dev/sde1 /media/usb0 and the drive mounted and was usable.

I tried rebooting to see if it would mount…the first time I went through this. Bad idea, had to reinstall.

The Google’s sends me to pages about reformatting a drive, but the drive is clearly ext4 and mounts, and is usable…as long as I do not try to use fstab. I am hoping I have a typo or something easy, but I sure cannot find it. I have watched Jay’s video covering fstab and read the relevant section in MUS, but those are not really troubleshooting resources. Any help would be appreciated.

defaults not default


Sorry…this thread could be deleted if desired.