Ubuntu Server 20.04.2 is getting the wrong address

Hi, I have problem with Ubuntu Server 20.4 LTS.
After restarting Ubuntu Server 20.04.2 (clear installation), It obtains the wrong IP address from DHCP server (Windows Server 2012 R2). It use bad MAC address such as this ‘9f6e852400020000ab117b61e29f5a2058bf’. When I run the command:

sudo dhclient -v -r ens160 && sudo dhclient -v ens160

the server obtains the correct registered IP address (and use MAC address as xx-xx-xx-xx-xx-xx). Both server run on VMware esxi 6.5 and the network uses only IPv4 (IPv6 is disabled).

Does anyone know why this is happening and is there a solution to this?

PS:
I thought, that problem was in Netplan, because on Ubuntu 16.4LTS wasn’t problem. On Ubuntu 18.4 & 20.4 LTS is problem. BUT, after upgrade Ubuntu 16.4LTS > Ubuntu 18.4LTS there isn’t problem, but when i Upgrade Ubuntu 16.4>18.4>20.4 there is problem with DHCP. So I uninstalled Netplan.io and used old setting (/etc/…/interfaces) and use post-up script with dhclient -r and dhclient. But this is not solution.

BTW: sorry for bad english.

I think this is your culprit:

Thx, problem solved.