Troubles with RetroPie-Tutorial

Hy. Following this guide i built RetroPie on Ubuntu minimal. Installation went fine, but i’m lost with two problems. Almost all cores worked out of the box, only standalone mupen64plus crashes with any game (all uncompressed .n64). I was looking for the runcommand.log to determine the problem, but found that the file is missing. Why won’t runcommand create logfiles? On google i found a thread where one had a similar problem with mupen64plus. He changed the audio from pulse to ALSA but when i do that, the emulator indeed starts on some few roms but it messes up the audio with extreme crackling to an unplayable state.

The second thing seems to be a power management issue. Every few minutes the monitor turns off while playing and the game hangs (as i can hear) until i move the mouse. This happens with any emulator even though the disable screensaver function in Retroarch is on and the screensaver timer in emulationstation is set to 0.

any help appreciated

16GB Ram
Nvidia GTX 960
San Disk Ultra Fit 32GB USB3.0 (as / carrying the system)
Ubuntu minimal 18.04
Retropie 4.7.7

I don’t have one in front of me, but if I remember correctly, runcommand does save a log file, and it does so underneath /dev/shm. What I find, is that it may not log errors there. But what it will do is print the command that it runs when it runs a game. Then you can run the same command yourself and see what the errors are. That’s how I usually troubleshoot things like this.

N64 is going to be a mixed bag no matter what. For some reason, the emulation scene with N64 isn’t anywhere near as efficient as other console emulators. That doesn’t mean you can’t run N64 games, sometimes you need to adjust them. For example, it’s not uncommon that one game will need custom settings applied, whereas other games won’t. It’s hit or miss, trial and error. If Nintendo ever releases an “N64 Mini” or something like that, the emulator community will reverse-engineer it completely in less than a week. Then the N64 emulation scene will be near flawless. Until then, we just have to deal with hit or miss quality, unfortunately. I don’t say that to discourage you though, you CAN get a good experience with N64 games. It just takes a bit of tweaking.

For the screen blanking, there are two ways to solve it off the top of my head:

1.) Install caffeine, set it to launch automatically. You can copy its desktop file from /usr/share/applications/caffeine.desktop it to ~/.config/autostart/caffeine.desktop. If I remember correctly, that SHOULD take care of it.

2.) If not, install xfce4-power-manager, then set it to autostart. After installing it, run
xfce4-power-manager-settings and configure it to never sleep.

Try option 1 first, that’s the most likely to help and results in fewer dependencies being installed.

I hope that helps.

Thanks jay. The weird thing is, that /dev/shm/ doesn’t hold any log file. It’s simply not there. I tried to # find runcommand.log but… nada on that drive. Meanwhile i dropped that build. Some guy told me to try Batocera for X86. They have a ready to run image which i’m currently trying. Looks nice but also has it’s problems :man_facepalming:. Comming from Pi4 platform i really thought, that N64 is a tough nut, but there I’m running 720p full speed with hires textures.

Anyways, i’ll keep your solutions in mind, since i already see myself turning back to the “RetroPie on Ubuntu Minimal” approach.
I appreciate your time.

Is runcommand disabled in Retropie-Setup? Just a thought.