Thinkpad X1 Extreme Gen 2

I’d like to share my experience of using Linux on the X1 Extreme G2.

Model specs:

  • 6-core i7-9750
  • 4K display

Linux distro used:

  • Pop OS 19.10 (NVIDIA edition)

What works:

  • Everything, including the brightness, volume, etc fn keys.

What doesn’t:

  • Waking from sleep fails most times. The system turns back on, but all screens (including the internal one) stay black. Sometimes logging in via SSH and resetting Gnome works, sometimes restarting X works, sometimes I have to reboot the machine before the screens come back on.
  • Adjusting display settings sometimes results in the whole system freezing, especially when a screen is connected via HDMI.

My setup might not be typical: I’m using both Thunderbolt ports to drive 3 external displays - two displays via a single cable (DisplayPort daisy-chaining) and a third display via the other TB3 port. At the office I also use three external displays, two via daisy-chaining but the third via HDMI. Now, to be fair, Windows is also struggling with this and it takes the system sometimes up to 10 seconds after waking from sleep before all displays work properly.

This is not a criticism of Pop OS 19.10. Understandably, System76 has to priortize their own line of laptops; I thoroughly enjoyed using their Linux distro on the desktop for a week - in that one week I learned so much about Linux that I really did not want to go back to Windows.

I watched Jay’s review of the X1 Extreme G1, he claims everything works out of the box using Pop OS. I will most likely try Ubuntu 20.04 and Pop OS 20.04 as soon as they become available and report back in this forum.

Has anyone gotten their X1 Extreme G2 working flawlessly under Linux?

Thanks for posting! I was thinking of buying that laptop myself.

I’m curious, what happens when you try 20.04? I’m not saying you should wipe and reload, but what about trying Ubuntu 20.04 Daily from the live environment, put it to sleep, wake it up, and see what happens?

It would be very telling if it works in 20.04, which would mean that the driver support in 19.10 is behind.

Sorry for the delayed response - had a very busy week.

I just booted the X1EG2 from a Ubuntu 20.04 Desktop USB stick. Took a while but got to the desktop. Wanted to open settings to check which driver is being used (if any) for the NVIDIA card. Pressed Super, typed “settings” and enter; screen froze in the GNOME loading animation for the settings app. Tried switching to virtual terminal, nothing. Could only reset via power button. I’ll try again as soon as 20.04 is official released, will report back then.

Alex, look forward to your impressions of Ubuntu 20.04 LTS after the official release. I’m running this distro of Linux on my Acer Aspire laptop with Intel i7, 8th gen CPU and 12 GB of RAM. Love how it detected all the hardware, even printers, flawlessly.

Sorry for my late reply.

I recently installed PopOS 20.10 on the X1EG2 and was pleasantly surprise at how smooth everything worked. But after a few days standby started to work erratically - felt like 50-50 odds.

I like Linux because I use it on servers and I’m desperate to leave Windows behind but the most important thing is reliability for my use case. And I don’t have the time to troubleshoot my main work machine. So I’m back to Windows (with WSL), for now.

Maybe next time I will try Fedora - for which the X1EG2 is officially certified now - and see how that goes.

1 Like

I’m sorry to hear that your experience wasn’t great with suspend. As much as I wish it wasn’t the case, this behavior isn’t uncommon when you replace the operating system a computer shipped with, with something else entirely. Hardware support with Fedora (at least in my experience) is a step down from Ubuntu and Pop!_OS, but it’s still worth a shot.

In regards to Pop!_OS though, I’d be curious what the syslog says when you attempt to suspend, might shed some light on things.

1 Like


This thread is old and stale, but it is never inappropriate to share hardware-Linux infos… not when one considers the cost of the machines we buy.

I have a Thinkpad X1 Extreme Gen 2. Once secureboot was disabled, PopOS ran out it OK. That was about 1 year ago.

I have been thinking about the Dell XPS 13 Developer edition (Ubuntu), Thinkpad Carbon X1 Gen 8 (Fedora), System76 Serval and waiting for Lenovo to release their Linux X1 Extreme Gen 3.

I am used to Dell XPS and Lenovo X1 build quality. The X1 Extreme has been a good performing laptop.

Wish you the best.

1 Like

When I purchased my Acer Aspire laptop it came with Win 10 installed. I kept it around until the warranty expired, then dual-booted it with MX Linux. The only reason I didn’t remove Win 10 altogether was to retain my license just in case I needed to run a piece of software (proprietary most likely) that wasn’t available or that wouldn’t run properly in Linux.