System76 Darter Pro 7 - review?

It would be great to see a review of the Darp7 from System76. Yes, no, Maybe so ?



I’ll review any Linux laptop sent to me. Lately, System76 hasn’t sent as many computers to me as they used to. I honestly just think they forgot LOL. I’ve been meaning to ask them if they have any review units, but I recently purchased another device that’s on its way to me (not the darp7 though) so that’s currently my focus, but after that, I may reach out to them if my workload permits.

Thx Jay -

There are a few reasons I’m interested in this device, and also a few reasons I’m anxious.
On the plus side, it’s a device with respectable battery life, a gen11 Intel processor with better integrated graphics and supposed greater power efficiency, and it has gen-4 Thunderbolt and dual SSDl slots. Great.

I don’t game and for me there drawbacks about graphics management. Pop!_OS has been a disappoint for me in the past year, so it forced me to look at other distros, which of course have their own Optimus solutions. It’s a PIA, in my opinion. Also, the Reddit chat room for System76 has had a lot of dialogue about trouble with their proprietary firmware, which makes me nervous. I assume they’ll figure that out.

Anyway, your thoughts welcome, and thanks for the good common-sense advice.


I’m very surprised to hear that you’ve experienced problems with proprietary graphics and others are too.

On my end, Pop!_OS has handled graphics the best out of any distribution I’ve used. I leave it set to hybrid mode, then I right-click on the game icon, and click on the option to have it run the game on the proprietary card. And it works great. Both my Gazelle and Oryx Pro handle this flawlessly (both have custom firmware). My Thinkpad X1 Extreme (gen 1) works well with it too. It’s been perfect.

I’d be interested to hear more detail about the nature of the issues you’ve experienced.

Also, if there are issues, we should file a bug report. A lot of people miss that part. It’s essential to file a bug report about issues so they can be addressed (unless someone already did that).

Sorry. I unintentionally misled. I have had trouble with PoP!_OS and now run Manjaro and am really happy.
About a year ago the WiFi networking on my 3-year-old Gazelle would initialize and then crash. After opening a ticket and working with the tech support team it just went nowhere, so as a last ditch effort I changed to Manjaro and the issue went away entirely. For some reason I can’t recall, I went back to POP! and it worked fine for about a year, then my whole system started a pattern of suddenly crashing. Bam! No warning, no log info. Just a black screen. Back to tech support, and we tested all kinds of trouble isolation, concluding finally that the main board was gone. But then I switched back to Manjaro and it’s great. No trouble at all.
So, the issue with Optimus is that I just don’t trust Pop!_OS, which means that if I do sometime go with a Gazelle or Oryx, then I have deal wtih Majaro’s implementation of Optimus support. They’re a good team but even they admit it’s a hacky solution. And I really don’t need a graphics card because I’m not an academic engineer or a gamer. Just a garden-variety linux user.
So that’s the longer story. The Darter Pro looks great but for me, I need to wait until someone sits down with it for a week or two to review.
best regards,


I’m going to try to get my hands on the Darter Pro or the new Galago. I eventually want to review both. I’ll put up a poll on Twitter, and I’ll see which of the two wins out as being the one I should review first.

In regards to Manjaro, I haven’t used their implementation of Optimus as of yet, so I don’t have an opinion on that at all. I will say that anytime recently I’ve used Manjaro, I’ve been happy with it. But I’m inclined to feel that your negative experience with Pop!_OS is an edge-case. I am running Pop on a Thinkpad T480s, Thinkpad Extreme Gen 1, Thelio desktop, Lemur Pro, Oryx Pro, and a Gazelle. It’s been perfect for me. That’s why I find your experience odd, and there has to be an explanation.

Have you run memtest86 on your current Gazelle?

Hi Jay -
No doubt it’s odd :-> That’s certain. It’s bizarre.
Yes, I ran memtest overnight without issue, and stress-ng --matrix 0 -t 15m for 15 minutes, and then at 50% load for 30 minutes, all without any issue. There were other tests to try to isolate system components but we were never able to find anything. Actually, what’s even weirder (to me) is that’s I’m such a non-edge user. Nothing that should push the system. Also, that it would happen twice, in two different use cases (WiFi and system crash) is also strange. But no need to belabor this. Glad it works for you and others.
And thanks for your responses.

I can understand thinking that it may be better not to focus too much on your issue at this point, but the reason I am focusing on it is that it’s been my experience personally that unless you understand the true root-cause, the issue can (and often does) return later. Finding the solution also helps others if there’s someone else out there that’s searching Google for a similar issue.

Also, I submitted a request for a Darter Pro review unit, so assuming that’s accepted (and I think it will be) I’ll be reviewing that in a couple weeks or so.

NP, and I agree. I would have been happy to get to the root cause, and had a good experience with Sys76 support, but we were never able to find a cause. Tested memory, did load testing to try to flush out a thermal issue, installed a HDD and ran PoP! from that (to try to eliminate the SSD as cause) and even ran from a micro-SD, which is pretty hard sledding :-> We’d exhausted everything they could think of, short of sending the device in for RMA repair. It was their thinking it was some kind of main-board issue, which would have been weeks in transit and $600+. For a 4 year-old laptop, that’s a hard sell.

Sometimes you have to cut bait. It is possible that an update introduced a bug. Also, I had a theory that something in the thermal sensor / detection / interpretation was wacked because the system shutdown occured when the fans were running, as though the OS or firmware was protecting the CPU, but we couldn’t duplicate it even when I pushed the system hard for 20-25 minutes. And the temps were elevated during those tests, anyway. Beats me, Jay :-> When you have limited technical chops you’re at the mercy of best effort tech support.

As for the new Darter, that’s great. I look forward to seeing the review.

The new system supports PCIe gen4. I wonder about the power implications. Does that add more heat and cause the fans to go nuts, or just pull more from the battery. I also wonder if a user like me would ever even see a performance improvement.

Also, it’s great that is has Thunderbolt 4. I guess that’s an incremental improvement on 3 but I wonder if helps, and how.

Your thoughts about build quality would be great to hear.

The integrated graphics are supposed to be good. Does linux today have drivers that take full advantage of that?

Thanks again Jay

Whether or not the newer integrated graphics work better in Linux, that’s definitely something I intend to figure out. I’ll probably connect an eGPU to it as well, that might be a fun experiment.

Hi Jay -
A few questions for you, please:

How would you compare Tuxedo to System76? Are they both using Clevo products? Do you know if Tuxedo tweaks their laptops differently than System76 does?


Reid Vail

I am not sure about either question, to be honest. For me, it doesn’t matter at all whether or not they use Clevo as the baseline starting model. I judge the machines as they are, and when it comes to System76 I don’t consider their base models to be Clevo machines even if they actually are - with their firmware changes and other adjustments, a System76 Clevo is not a Clevo. I do know that they are in the process of getting away from using another model as a foundation, but the result of that effort is probably years away. With Tuxedo, I’ve been curious how they do what they do, especially considering some models have a button that launch their Tuxedo-specific app, so I’m really curious how they did that. I’m new to Tuxedo, but I do own one of their laptops and use it every day, so perhaps I’ll dive in more.