[solved] GRUB error after installing package

So I was following jays arch Linux installation tutorial, and after I installed the GRUB package, when I try to install GRUB, it gives me an error, here is a screenshot of that error! Thanks to @jay or whoever else who helps me in advance :smiley: :slight_smile:

That error appears because EFI boot is disabled in your BIOS. You’ll have to enable that. The last time I ran into this though, simply enabling EFI didn’t help, EFI had to be enabled before installing GRUB. So I had to enable EFI, then use the Arch install media and chroot back into the installation, and run the grub install command again. After that it should boot fine.

Ah… I have a very old machine so that explains it… thanks a lot @jay !!! Will respond later to update.

Well… looks like my machine doesn’t support EFI… Any alternatives you know to grub? @jay

PS : thanks for replying so fast!

@jay I was able to bypass it by using blocklists with the legacy mode…

pacman -S grub
grub-install /dev/sda --force

The rest is the same

I have a non-EFI tutorial that would’ve worked, but I may redo them all in 1-2 months.