Send the Homelab to the Attic

I don’t have any windows machines. So I am going to work on learning how to setup nfs. This is where I am at right now.


I modified my share to


and now I think I got it. on the synology I had to put in my exact ip. trying to include the whole subnet 55.1/24 gave the error permission denied.

This works and I have my first machine syncing.

I still want to figure out the nfs share on the truenas vm. I will spend time on that later.

For NFS, you want to export either the IP address, like 55.7, or the whole subnet, which would be 55.0/24, which is not the equivalent of 55.1/24. It might work, but I advise you use the proper subnetting.

On the truenas vm, I’m pretty sure the screenshot you sent has the 4tb pool shared, you just need to edit its export and you should be set.

1 Like

I had no idea I needed to use 0 instead of 1. Thanks for the tip.

I think I spoke to soon though. I thought I had my synology nfs share mounted, but now my local filesystem is full of syncthing files. It is mounted now but I have no permissions unless I am root. Root cannot change the permissions.

I have an option to map all users as admin on the nas, but is that the right way to do this? I saw a post about mapping the uuid of users on the nas and the server. Do I need to do something like that? Thanks again.


The ideal way is to make a folder inside the top level mounted folder and to give that folder permission / ownership to your user. Something like:
server:/export/path /mnt/nfs
mkdir /mnt/nfs/syncthing
chown user:user -R /mnt/nfs/syncthing
chmod 770 -R /mnt/nfs/syncthing
chmod 775 /mnt/nfs

Something like that. It can be done via the GUI, just make sure that after you do this, you change the permissions on the top level mount to 775, so other users will have read and execute (to be able to open the folder). The syncthing folder would be the one that needs the write permission and ownership for your user.

Reminder to change the syncthing folder over the new path.