Proxmox iGPU passthrough to LXC

I have set up my jellyfin server in a LXC with many other LXC proxmox works just great and due to the nice playlist I learned it quite quickly.

But I just couldn’t get igpu passthrough working, I spend days search trying, searching trying…

I really hope to get some help here as on proxmox forums I did not get an answer.

I want to run jellyfin with igpu passthrough, I did it using tteks automated scrint and compared the actual code and nearly all websites suggested this code.
But after setting everything up jellyfin errors out in the GUI with a pretty general message:


Linksheet: linksheet_igpu-problems - (Due to new user limitations…)

Jellyfin log probably says the most. Jellyfin support mods sent me away, they don’t provide support for this.

Huge thanks for any answers!

Have you attempted to set the container options in proxmox to unprivileged = no, keyctl = yes and nesting = yes? Maybe even add the experimental create device nodes (although not sure what the last one does).

This will basically run the container like any other program on your system, unconfined by the UID masking of cgroups, since the container will have access to /dev, /proc and /sys on the main proxmox system, but it might get it working.

Note that it’s possible you need to have the same intel driver version inside the container and on the host to get it working.

Set it to unprivileged?
Never heard that only the other way, but sure let me try.

Also I was unsure how install those intel drivers I tried multiple packages and basically each attempt successfully install them ended in some lib package blocking up my whole apt upgrade function with some error and apt --fix-broken or so.
Graphics should be intel 530HD

Huge thanks, and how quick of an answer, your a legend!

That means you should disable unprivileged container, meaning it will be privileged, meaning it will have full access to the system.

Just install the intel mesa drivers. If you run debian inside the container, just make sure you pin the version in apt. You should not need to install anything by downloading the driver from a website, it should be in the repo of most major distributions.

Keyctl can only be yes if unpriviledged lxc.

Experimental create devices is now turned on, and uninstalled all software from intel and reinstalled mesa-utils.

[AVHWDeviceContext @ 0x55c6e3ba5280] No VA display found for any default device.
Device creation failed: -22.
Failed to set value ‘vaapi=va:,driver=iHD,kernel_driver=i915’ for option ‘init_hw_device’: Invalid argument

Tested and is still not working, output of a jellyfin(ffmpeg) transcode log.