Problems with Arch Linux Installation

Hello, I followed the Arch Linux installation guide on youtube that LearnLinux put out thats 2 hours long. I did everything the same besides a few differences. My problem is I dont understand whats wrong. I did a UEFI grub install of AudioPhile linux which is based on Arch. Its not encrypted, and when I pick my kernel I get sent to a TTY interface. It asks me to log in and enter my password, so I do. then it just gives me a command line with a black screen like any other TTY instance.

I ran:
"sudo pacman -S intel-uicode xorg-server nvidia nvidia-lts "
“sudo pacman -S plasma-meta kde-applications sddm” and
“sudo systemctl enable sddm” just like it said to do in the video, but I don’t get any graphical login screen or the ability to boot into my desktop environment.

Would anyone be able to help me? (:

After installing the intel ucode package, you need to re-generate grub with grub-mkconfig -o /boot/grub/grub.cfg
Also, systemctl enable sddm only enables sddm to start at boot, so re-boot and see if it works.
Hope this helped!

I just tried that and nothing has changed ):