No sound when RST switched to AHCI

Ok, so this has been a nightmare. I want desperately to switch to Mont from windows on my new Dell Inspiron, but there are two issues that are preventing me from doing so, which may or may not be related

  1. When I switch to AHCI from RST in the BIOS menu, the sound no lo no we works when I boot up the mint demo. However it works when RST is on, but it will not let me install

  2. I get a quick flash after the Grub menu that says “Failed to parse WDG method.” I don’t know what this means and cannot for the life of me figure it out, let alone how to fix it. I’ve checked every website and forum on the planet, and it is beyond discouraging. I really need some help, anything would be greatly appreciated

Can you try another distro, like Manjaro or something, just to see if that works?

I tried Ubuntu and same thing

Oh, I meant like totally different.

I note that others have had “Failed to parse WDG method.” when the hardware is newer, your Dell”, before the kernel can update to it. Now I assume that RST that you refer to is Intel’s “Rapid Storage Technology” where it creates several disks into a RAID 0 configuration to speed up access. I really know nothing about it other than it is for Windows. However RAID itself can cause issues unless the disks are completely formatted. However I know from experience that AHCI with certain OSes with some Mobos can cause issues and sometimes it is not just switching on AHCI but also other switches in the BIOS/UEFI. I had this with one of my older motherboards, though I cannot remember what I did. There was also the fact that I had to put certain keys in the grub text files to get both USB2 and USB3 working and not to blank the screen, and something similar maybe required. DELL do/did support Linux, they were at one time selling computers with it installed and may still do, and certainly do with servers, so it maybe worth contacting them to see what they say. Have you been on the official Dell forum?

Edit: Just an after thought. Have you turned off secure boot? From your comments there’s no sound with AHCI though you can install. Is that correct? Not being able to install with RST enabled makes sense as you need drivers with it that are available in Windows, but not Linux.

Incidentally I have no idea what WDG is, though in Windows it relates to the Windows Device Group, so it could relate to the watch dog timer. Like many things when trying to resolve issues, you only come across the acronyms in the course of that and hopefully learn what they relate to.

This is a complicated subject. SATA v.s. PCIe drives and their associated BIOS settings can be mind-twisting. Throw in Intel RST plus a previous Windows install, and you’re really in deep weeds.

It may be helpful to know a bit more about the hardware components of the laptop (if possible):

  • Laptop Brand you said was Dell, Inspiron
  • What motherboard does it have, actuual model number of the laptop
  • What BIOS version is it on
  • What Hard drives and how many, SATA SSD or NVME
  • If you can find it, what Audio Device does it have?

The more info you can share, the better people can advise. I am about 99% certain NVME is not backward compatible with AHCI. Additionally, I believe you need at least 2x drives to enable RST (could be wrong). If Windows was previously installed, there’s many potential issues.

See : Intel RST Ubuntu Documentation

Where the Audio issue is will be a matter of seeing if it’s detected, and the right modules or firmware is being loaded for it. This could possibly be a kernel issue, but it’s hard to say at this point.

While under Mint with AHCI enabled in the BIOS, try using dmesg to see if there is an error / warning that will give you more clues as to what’s going on.

sudo dmesg --level=err,warn

If you see anything obvious from dmesg, post it back and maybe others can help troubleshoot further based on your findings.


This post is gold.

With the absolute dearth of BIOS and hardware documentation put out by OEMs, resolving such troubles as the OP describes is a can of worms and an exercise in frustration. That can of worms is 10 times worse on Linux. At least that has been my experience. Not that anything I’ve said here helps other to indicate that all of us are in the same boat.

Perhaps search ArchLinux forums for a solution ? If one is likely to find a fix, then I have found that the greatest probability is there - even for non-Arch distros.

K17MT is right and with RST from what I gather can run up to 6 drives configured as one big drive so similar to RAID 0 though I have never come across a normal RAID 0 with that number of disks. NVME runs off the PCIe bus so does SATA though in not such an efficient way. If you look at either the Ubuntu documentation or the more in depth Intel’s it would appear that Linux can actually run on RST but it does depend on the motherboard, UEFI, and the actual version of Linux. If it doesn’t detect the drives then revert to AHCI.

One thing that could be helpful would also be more detailed information on setting up the UEFI in different configurations. Unfortunately you seldom get that information these days from either the computer/MoBo producer or elsewhere. BTW some BIOS/UEFIs have a separate section for RAID so it is worth checking that is correct. Is this similar to your UEFI.

By the way did you check within Linux that audio is actually enabled and working. I had a real problem with a webcam with an integrated mic over this and had to play around and make changes before the audio/Mic would work together though normal sound was OK.

I think maybe be careful about on-board “RAID” though:

1 Like