Nextcloud - Complete Setup Guide

I tried this tutorial once when nextcloud-20.0.7 was actual and it worked.

Ubuntu 20.04.2 LTS

Now with nextcloud-21.0.2 I can not Configure Nextcloud…
2.22 Chapter
When calling my url which before showed me the Apache default page, now I get this error instead the Nextcloud page

* @author Joas Schilling * @author Jörn Friedrich Dreyer * @author Lukas Reschke * @author Morris Jobke * @author Robin Appelman * @author Roeland Jago Douma * @author Sergio Bertolín * @author Thomas Müller * @author Vincent Petry * * @license AGPL-3.0 * * This code is free software: you can redistribute it and/or modify * it under the terms of the GNU Affero General Public License, version 3, * as published by the Free Software Foundation. * * This program is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU Affero General Public License for more details. * * You should have received a copy of the GNU Affero General Public License, version 3, * along with this program. If not, see * */ require_once __DIR__ . '/lib/versioncheck.php'; try { require_once __DIR__ . '/lib/base.php'; OC::handleRequest(); } catch (\OC\ServiceUnavailableException $ex) { \OC::$server->getLogger()->logException($ex, ['app' => 'index']); //show the user a detailed error page OC_Template::printExceptionErrorPage($ex, 503); } catch (\OC\HintException $ex) { try { OC_Template::printErrorPage($ex->getMessage(), $ex->getHint(), 503); } catch (Exception $ex2) { try { \OC::$server->getLogger()->logException($ex, ['app' => 'index']); \OC::$server->getLogger()->logException($ex2, ['app' => 'index']); } catch (Throwable $e) { // no way to log it properly - but to avoid a white page of death we try harder and ignore this one here } //show the user a detailed error page OC_Template::printExceptionErrorPage($ex, 500); } } catch (\OC\User\LoginException $ex) { OC_Template::printErrorPage($ex->getMessage(), $ex->getMessage(), 403); } catch (Exception $ex) { \OC::$server->getLogger()->logException($ex, ['app' => 'index']); //show the user a detailed error page OC_Template::printExceptionErrorPage($ex, 500); } catch (Error $ex) { try { \OC::$server->getLogger()->logException($ex, ['app' => 'index']); } catch (Error $e) { http_response_code(500); header('Content-Type: text/plain; charset=utf-8'); print("Internal Server Error\n\n"); print("The server encountered an internal error and was unable to complete your request.\n"); print("Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.\n"); print("More details can be found in the webserver log.\n"); throw $ex; } OC_Template::printExceptionErrorPage($ex, 500); } 

To add: I needed to install

sudo apt-get install apache2

Without it said after:

sudo apt install php php-apcu php-bcmath php-cli php-common php-curl php-gd php-gmp php-imagick php-intl php-mbstring php-mysql php-zip php-xml
Warning: Could not load Apache 2.4 maintainer script helper.

Can you help?
Thank you.

Since you are using Ubuntu as your server, have you tried:

snap install nextcloud

I believe this is one of the preferred methods for installing NextCloud on Ubuntu.

snap install nextcloud would be new topic for me.
Got NextCloud with Jays tutorial running by first installing Apache with a virtual host before.
But the last tutorial step
sudo add-apt-repository ppa:certbot/certbot
it says: “The PPA has been DEPRECATED.”

Its recommended to use snap: Certbot - Ubuntufocal Apache

The snap package is sometimes really old, which is why I don’t always point people to that. But it might’ve been updated, it’s been a while since I’ve looked at it.

I haven’t seen that error before, but it looks to me as though a PHP mod isn’t enabled that it needs.

You can run the a2dismod command, and then press CTRL+C to cancel that without making changes. You normally use that command to disable a mod, but it shows you a list of currently enabled mods, so you can make sure everything you’ve installed (the php packages) are listed in that list. If not, you can enable the missing extension with:


Also, make sure you’ve added all the php.ini tweaks.