Nextcloud complete guide error

Hey there

I tried to set up a Nextcloud with Linode and your guide on Youtube (“The comlete guide to nextcloud”, or so).
Most of the commands worked and my nextcloud is running now. Since my Domain isn’t set up now, and it could need some hours for “activating it”, i wasn’t able to do one of the last command to set up encryption for my nextcloud. But this should work as soon as my domain does. So this shouldn’t be a problem. Even though, i can’t use my nextcloud at the moment, due to missing encryption with TLS.

I had an error with the memcache setup in the following command:

xxx@nextcloud:~$ sudo php /var/www/ db:add-missing-indices
An unhandled exception has been thrown:
OC\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

So it looks like some php module isn’t installed or enabled. But i do not know which of the modules is needed for the memcache setup. So could you help me out with a hint, which module(s) i need to install and enable again, to be sure this command will work?

Thanks a lot for your help



Hey Mandelbrot,

The PHP module in question is php-apcu (perhaps also php-apcu-bc, but that one should be auto-installed along).

Assuming you’re using Debian/Ubuntu, you can check if the module is installed with:

$ apt search php-apcu

If the apt package shows [installed] or [installed, automatic] at the end you should be fine, otherwise install it with:

$ sudo apt install php-apcu

As far as I’m aware, the documentation does not mention any explicit enabling of a module. You can find more info here: Memory caching — Nextcloud latest Administration Manual latest documentation.

Hope this helps,


Ok. Pakage is intalled (both).
Will read the documantation later, perhaps i’ll find something helpful.

Short question:
I think this shouldn’t be a problem. But my domain isn’t active, since i’m waiting for the A-Record to be “online”. could this be the problem?


I don’t think that will be a problem in this case.

I seem to remember that I had the same error message when I first installed Nextcloud following Jay’s instructions, a week or so ago. I checked to make sure that php-acpu module was installed (it was). The error seemed to go away by itself, eventually, after a couple hours of further tinkering, possibly due to a system re-boot?
Anyway, Nextcloud has been running faultessly for me for a week now, with good performance.