New hardware - Linux install issues [SOLVED]

I’m not sure where to post this, hoping this is the place :()

I know nothing about hardware. . . . .

I just had to return a new ACER, booting from USB was disabled/not allowed. Now I’m looking at 2 Dell Inspirons 3891 that may have to go back too, they only boot in UEFI, and - no options for CD or USB boot. They do show boot options for IPv4 & IPv6 - What?

I’ve been lucky up to now installing Linux on old laptops 2, old Dell desktops 4. I want some new ones - to run Proxmox (influenced by @Jay) and play around on. The other for a simple home PC, or home-lab (must stop listening to @Jay LOL)

I found this: posted 2019 on Dell Community

LEGACY Booting is no longer supported past SKYLAKE.

32 BIT OS and Drivers are no longer supported by anyone.

64 BIT windows 10 or Linux in UEFI mode is the only thing supported going forward.

This means ancient Linux that uses GRUB/MSDOS MBR booting is also not supported.

CSM with MBR legacy booting is gone.

The good news is that the Current UBUNTU works on current systems as well as ancient ones.

Will there be a new way to install Linux on these new systems?

And is there some hardware middle ground $price, for Linux systems?

Thanks ~

Are you looking for new hardware that supports MBR/BIOS boot? That begs the question, why? I have done a uefi install of every distro I have tried. Ubuntu, Manjaro, PopOS, Fedora, and Arch have all supported uefi. I did, however, have to disable secure boot in the bios settings to get the USB drive to boot. Try looking for that setting before returning anything else that you otherwise like. It took me a while to figure out that one.

2 Likes

Hi hulxmash,
Hum, I guess I’m not explaining correctly -

Normally I 1. disable secure boot, 2. enable Legacy boot (so the USB & CD boot
options appear and 3. move USB up to the top of the boot order, save and exit.

  1. Make my bootable ios USB stick. And boot from it.

So my question is -

If I can’t enable Legacy, so I have USB as a boot option,
then how do I do this process?

There must be something I’m missing, because
when I have UEFI as boot mode even with secure boot disabled, boot from USB
is not an option, and my bootable USB when inserted is not recognized and normal boot happens.

If it’s not a UEFI problem, then why all the steps say to switch to Legacy. Why have
I not seen a how-to that just says disable secure boot, there you go… install away.

What am I missing?

I’ve never used a Dell before but a quick google says that even when in UEFI, pressing f2 during the dell logo will bring you to the bios settings, which clearly you are familiar with, and then press f12 to select which device to boot from. If your bootable usb isn’t appearing in the list then I would try another USB port.

The documentation I saw there says that usb 2.0 devices are not supported. So if your bootable usb is usb 3.0 or newer it should work fine.

I have only used uefi boot on all my Linux installs (that weren’t in a vm), and I’ve never had an issue. But I’ve never owned a Dell either.

I would take what the vendor sites have to say with a very large grain of salt! They were, and often still are, under extreme pressure to push customers towards the latest version of windows. So they say things like the nonsense you saw on the Dell community site.

FWIW, vendors’ community sites are often part of their marketing department rather than engineering or development.

As @hulxmash says, there is always a way to enter the system bios at boot up. It usually involves pressing a specific key while the system is booting. If you google for “your system brand/model keypress boot bios” you can usually find out how to do it. From there you will see things like ‘bios mode’, trusted compute platform’, and ‘secure boot’ with which you can experiment. Each vendor seems to call them slightly different things.

FWIW, I think I have used UEFI for all hardware and distros that have been released in the last 4-5 years.

I don’t think I have ever come across an situation where I was unable to boot from USB due to the bios mode.

Another thought, what disto are you trying to install,what are you using to burn the USB boot drive, and what type of USB drive are you using. I have come across situations where the USB drive fails if burned with specific USB writing utilities.

A final thought. Have you tried different USB ports on you computer. Sometimes certain ports do not come up quickly enough to boot from.

The documentation I saw there says that usb 2.0 devices are not supported. So if your bootable usb is usb 3.0 or newer it should work fine.

This is good to know. I didn’t come across that, I wonder if a USB dongle would work, I’ll be giving it and a new usb 3.0 thumb drive a try.

I have only used uefi boot on all my Linux installs (that weren’t in a vm), and I’ve never had an issue. But I’ve never owned a Dell either.

Then can you tell me your process, in the Bios, what changes you make?

I don’t think I have ever come across an situation where I was unable to boot from USB due to the bios mode.

Really? Can you then tell me your process for installing Linux on a newer machine…? Because I’m finding the bios has changed.

I’ve listed the process I’ve used, many times now, the process I found online when searching for How-To. I’ve never found any other methods for installing, so my curiosity has been peeked. I’ve very much a hardware noob, and appreciate your suggestions.

Distros: I want to try Pop and Manjaro, I’ve used Linux Mint, and Ubuntu before on my other installs, with GNOME, Xfce and Cinnamon - but only found Cinnamon did not give me issues and and lots . . . of pain.
So Manjaro/Cinnamon it is with fingers crossed! Is this a frankenstein monster, hum…

I usually use Rufus, but did use Etcher this last time.

I will do some more testing and post back ~

It seems like you have only tried disabling secure boot in the BIOS, then attempting to move CD/USB to the top of the boot list, then reboot with the USB drive inserted, but then it fails to boot off of the USB flash drive.

Have you tried the following steps?:

  1. Enter BIOS and disable all references to secure boot.
  2. Save and Exit the BIOS
  3. With the computer off, insert the USB flash drive
  4. Turn on the power, and enter the UEFI boot menu (usually a different key needs to be pressed to enter the UEFI boot menu instead of the key that needs to be pressed to enter into the BIOS settings)
  5. Find the USB drive in the UEFI boot menu, select it and let the computer boot off of the USB flash drive. (if the USB drive is not listed in the UEFI boot menu, I would double check to make sure all references to secure boot in the BIOS are still off)

Also for putting an ISO on a flash drive, I have begun to prefer the Fedora Media Writer app that you can use on Windows even over the other options that are out there.

1 Like

I agree with everything mowest has said here. From what I read last night you should be able to get to the boot menu by spamming the F12 key during the initial start up when the dell logo appears. A boot menu should appear where you can select what device you wan to boot from. If your thumb stick isn’t listed then try another usb port. Or maybe your thumb drive is USB 2.0 and your hardware doesn’t support booting from it.

I have used both Rufus and Etcher without any problems. But I have had issues booting from Manjaro. This will only be an issue if you do start booting from the usb drive, but there have been a couple of instances where the Manjaro image didn’t have the drivers for the hardware I was using, (that’s how I ended up using a PopOS install). It was fixed a week or so later, but it think it’s because of the rolling release nature of manjaro that something was messed up in the install image. So if you do encounter an issue with installing that, maybe come back to it later if you still want to try it. But of course if it’s for the cinnamon desktop you can install that on any distribution.

When I have installed linux on both my of my newer machines, a laptop, and a desktop I built last year, the only setting I needed to change in the bios was to disable secure boot. Only one setting in the bios changed. After that it was simply a matter of using the boot menu to boot from the usb. The installers were pretty simple from there. Except for Arch. Arch is a little more involved.

Ah Ha! I’ve done it… and it is a extra set of Bios tweaks.

@Mowest - You are 100% correct, I wish I had seen your post. But I was out searching, and came across the same info, it is the part of this puzzle that loads the USB drive.
For step 4. I now had to press F2, instead of F12…This looks the same as F12 bios, except you will now see the USB drive option in boot order and be able to move it into 1st place…And that is how I finally got my USB drive to load!

Also, after the PC recognized the USB drive and let me test out Manjaro, it could not install due to 1. no partitions, and two other big errors I’ve forgotten now. So on to more bios tweaks…

in your bios UEFI mode - Save/Apply after each step

  1. disable secure boot
  2. disable fastboot
    {Both of these I had already done. In my case thorough boot
    was already set}
  3. disks on AHCI {drives: mine were set to RAID}
  4. no legacy {not an option for my new bios}
  5. no CSM {this was found under security, and I had to disable it}

What saved me was the fact that my bios had a search were I could find these.

So very different from my usual experience, but I’m glad I’m in and setting up Manjaro/Cinnamon - I do have massive keyring issues now, so I’ll save that battle for another day.

I hope this helps others in their journey ~

3 Likes

I’m glad to hear that you stuck with it and got it working.

Step 3 Update: Seems that only my SSD 256 drive was set as AHCI, because it had the Windows 10 installed, and so that was the drive Linux erased and installed to. I will now have to format my HDD drive from Linux so that Linux will recognize it.

You don’t have to format it for Linux to recognize it, but I would recommend formatting and changing the partition type to one of the Linux variants if you are going to use that HDD for Linux only.

Well, by recognize, I mean I cannot use the drive at all now that my Linux OS is installed. I’m not sure what your definition of recognize is Mr McBride :slight_smile:

BTW: I will never use Windows again as a bare metal OS, but the idea of a VM of sorts - If I could install a fresh Win 7 pro - and use it off line, that would be sweet.

I meant that I used to have HDD’s and currently have USB thumb drives that use non-Linux partitions/formats and I don’t have any issues with them.

I’ve access HDD’s from WinXP to Win10, to NTFS, and usb thumb drives using FAT/FAT32 with not issues. IIRC, I did have to install a driver in order to access an NTFS drive.

Like you, I’ve removed Windows from all of my laptops and workstations. My only Windows experience these days is on my work laptop (and I would change that if they would let me).

@Mr_McBride hum, interesting… well something with my HDD is not happy with my Linux and visa versa. But that’s good to know, thank you.

Hmm, I would be interested to know what GPart’d would list or identify the HDD as having.

If GPart’d can read the partition type, there is hope that you could get the HDD working in Linux.