New Arch Installation - Stuck at "loading initial ramdisk"

Hello! Although I’ve been somewhat familiar with Debian-based distros, I’m a complete newbie to Arch Linux. I followed the 2-hour tutorial video from Learn Linux TV to install Arch. I made the partitions, installed the system(as kernels both linux and linux-lts) and grub, then rebooted and all of it seemed completely fine. Then I installed XFCE and light dm and rebooted again. This time I got stuck at

    Booting 'Arch Linux'
Loading Linux linux-lts ...
Loading initial ramdisk ...

I tried pressing the button e at grub and adding “nomodeset” “acpi=off” “iommu=soft” “ignore_loglevel” seperately and together, also deleting “quiet”, but these did not work, the error persisted.

I don’t know what to do really. There could be a lot of missing info in my topic, I don’t really know which infos are needed exactly. I’ll certainly provide the infos as they are asked for. I am going to be very grateful if this can be solved. Thank you guys in advance!

Welcome to the forum!

There isn’t much to find out when the system hadn’t even booted. Maybe with a debug flag in grub. The initramfs is the contents that the PC needs to load into ram. I would go back into the live env, mount everything, chroot into it and rerun mkinitramfs (or was it mkinitcpio for Arch?) and update grub.

You could also try to switch the kernel to the latest one instead of lts.