Jasper's Homelab Adventure

Hey all,

I thought it would be a fun idea to open a topic about my own homelab and bring you guys along my (mis)adventures in trying out things as a casual tech enthusiast.

Let’s start at the beginning. It started about 1-2 years ago, when I decided I wanted to build a new workstation PC that could fit inside a mini-ITX case. I kept the old PC but took out some of the parts for my new PC, like memory and the video card.
After the old PC sat around for a while, I decided to rebuild it as a render PC so that I could render 3D animations on it and play video games without burning my current PC down. This worked for about a month until Windows decided the license was null-and-void due to a hardware change (classic!). I decided to bite the bullet and learn working with Linux more seriously by running Ubuntu (server) on it.

I had no clue at the time...

My previous attempts consisted of installing Ubuntu via WSL, changing directory, not understanding how I would return to my home directory and uninstalling it again.

Over time, I installed more services (like my Unifi controller) and slowly learned to work with my server without messing it up and deleting all my data, part of that thanks to learning from Jay’s channel. About 8 months ago I converted the server to run Proxmox as a hypervisor, allowing a separation of concerns by putting each application in it’s own VM/container. Over time, the amount of things I’ve been running has only increased, including running my own Nextcloud instance.
Now that I have a job and stable income again, I was also able to recently upgrade my server with more RAM and hard disks for a TrueNAS setup, which I currently use to store my Nextcloud data on.

So that’s my story so far, I’ll make sure to share more (mis)adventures here as things develop. I’m currently looking into making a backup solution for my Nextcloud service, which has been… let’s just say, not production ready… :sweat_smile:

Cheers!

2 Likes

Inconceivable! :joy:

2 Likes

What a fun adventure! It’ll be interesting to see how it develops.

Small update: I got the backup script working for my Nextcloud instance. I ran into an interesting problem where backups would get created successfully, but restoring the backup fails just after deleting the old data folder (leaving me with nothing :sweat_smile:).

So, recently I moved my Nextcloud data folder to my NAS (TrueNAS) using an NFS share, at the root of that share/dataset. When the backup-restore script runs, it first removes the old data directory and everything inside it. But because I put my data directly inside the NFS mountpoint (so not a subdirectory), the script tried to also remove the mountpoint. This lead to Linux trying to unmount the NFS share (and failing because it was busy removing stuff).
After a bit of manual restoring (thankfully the backup itself is OK), I moved my data folder into a subdirectory inside my NFS share so the deletion wouldn’t try to unmount the share. I’m quite happy to report that backup AND restore works as it should. :grin:

If anyone is interested in the backup script I used, it’s this one: Scripts for backup/restore - 📑 How to - Nextcloud community

1 Like