Issues with Debian 12

When installing Debian 12 on my pc. I ran into two issues:

  • Kernel wasn’t signed with a valid boot signature, so secure boot block booting Debain12. Turning secure boot off solved that issue.
  • The second issue I have with getting Debian 12 to with the display output (DisplayPort or HDMI) of my Dell Dock WD19S. With Debian 11 I had not issues with it, but I just cannot get it work with Debian 12. During the installation everything is working fine, but after the first reboot I just have a black screen. Switching to Terminal via Ctrl-F6, F7 etc… doesn´t work either. When plugging in my DisplayPort cable straight into the PC everything is working fine. Even tried with a HDMI cable connected to the dock and the monitor. Debian 12 recognizes a 2nd monitor, but still a black screen on the monitor. I have made sure that the screens were cloned in Gnome.

The issue only occurs with Debian 12. Ubuntu, Fedora, Debian 11 don´t have this issue. I didn´t see any driver issues in the logs. And the keyboard, webcam are working fine via the docking station, except for the monitor. Any suggestions on how-to troubleshoot this ?

I am now back to Ubuntu 22.04.2 LTS which has no issues.

Thank is in advance!

UPDATE: Looks like it is kernel related see:

UPDATE: I can now definitely can confirm it is a kernel issue. When using an older kernel (version 5.10) everything is ok.

Looks like it is kernel related

that thread is referring to a lenovo dock, not dell
also, it says the problem occurs after coming out of suspend
different hardware, different problem

I can now definitely can confirm it is a kernel issue.

I cannot reproduce ( kernel). Using a latitude notebook with a WD19S dock. Installed debian 12 and after restarting, external display (DP) came up immediately through the dock.

I’m not seeing this as a kernel issue either. Linux has had 100% coverage for these docks since sometime in the 5.x kernel series, it might’ve happened in the 4.x series I can’t remember. It’s been supported for a long time.

What GPU do you have?

As far as I understand It’s seem to be specific for AMD GPU’s. I have a “AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx” (which is an APU). It’s works on older kernels (5.10 en 6.0.0-0), but not on the newer ones ( and 6.3.01).

I have the exact issue as described in this thread

BTW: The secure boot problem was solved by selecting Yes to the "Update NVRAM variables to automatically boot into debian ? ". The question comes up during an advanced installation. I was doing an advanced installation to have the btrfs subvolumes properly mounted for timeshift.

Have you tried installing the amd firmware package? It really shouldn’t be necessary, but if it fixes this, then that would be interesting.

I have tried it, but it did not solve the issue. Even tried the kernel from ubuntu 23.04 (which is version 6.2) as an experiment , which gave a screen but the resolution was a mess.

I also found these messages: and Ryzen 3500U and 5650U: StandBy and External Monitors broken since >= 6.1 (#2492) · Issues · drm / amd · GitLab

So there seems as issue with AMD GPU’s icw USB-C Displayport docking stations in the 6.1 and higher kernels. For now it’s working fine with kernel 6.0.0-6.

So as an option for the future. If your hardware does not work, you can also try an older kernel instead of a newer one. :sunglasses:

Final update. Kernel 6.1.0-0.deb11.7-amd64 (which is the latest backport kernel for debian 11) is the most recent kernel that works. That is good enough for now. Hopefully it will be fixed in the debian 12.1 release.

Good job tracking that down! It was very surprising to see this issue happen, especially considering that once hardware works in Linux it’s usually not touched but I’m glad it’s been tracked down at least. This might mean that I’ll run into this on another laptop that has AMD when I get around to installing it there.