Conky Manager will not install

Hi, I am running Pop os 21.10 on a Lenovo Tiny pc. I have added the repository for Conky and Conky Manager 2 to my list of sources but the software will not install.

Is this blocked by Pop OPS in the interests of stability or is there a way to install the desktop clock and system information Conky provides?

I’m not familiar with special repos for Conky and Conky Manager 2. I’m also not very familiar with Pop OS 21.10, but I will give this a try.

Hi, Thanks for the reply and your suggestions.

I am new to using the terminal but had previously installed Conky manager using these commands below in Zorin 16 that I got from someone on the Zorin OS forum when I was first starting up in Linux.

sudo add-apt-repository ppa:tomtomtom/conky-manager

sudo apt-get update && sudo apt install conky-manager2

I saw the Conky entries in Synaptic package manager but not in the Pop OS store but, as there was no Conky manager 2 (GUI) to use, I thought i would try what had worked for me before in Zorin. I entered these 2 commands but could not then find the programme anywhere.

Just tried again with these commands and there seems to be a problem with the Impish release (which is the newest version I think? See results below:

$ sudo add-apt-repository ppa:tomtomtom/conky-manager
*[sudo] password for philneale: *
Repository: ‘deb Index of /tomtomtom/conky-manager/ubuntu impish main’
Description:
Debian packages for versions 18.04 and newer.

Also packages for the fork [1] conky-manager2 for versions 20.04 and newer.

[1] GitHub - zcot/conky-manager2: Fork of GUI for managing Conky widgets. Support added for latest conky config version, and works with Ubuntu 16-21, Mint 18-20 and more.
More info: conky-manager : tomtomtom
Adding repository.
Press [ENTER] to continue or Ctrl-c to cancel.
Adding deb entry to /etc/apt/sources.list.d/tomtomtom-ubuntu-conky-manager-impish.list
Adding disabled deb-src entry to /etc/apt/sources.list.d/tomtomtom-ubuntu-conky-manager-impish.list
Adding key to /etc/apt/trusted.gpg.d/tomtomtom-ubuntu-conky-manager.gpg with fingerprint CEC312CC5ED8215A6E0EFC49B90E9186F0E836FB
Ign:1 Index of /tomtomtom/conky-manager/ubuntu impish InRelease
*Hit:2 Index of /ubuntuhandbook1/apps/ubuntu hirsute InRelease *
*Hit:3 https://brave-browser-apt-release.s3.brave.com stable InRelease *
*Err:4 Index of /tomtomtom/conky-manager/ubuntu impish Release *

It seems the PPA is not supported in the newest release of Pop OS.

Thanks @Opsman2021 for posting the output of those commands. Since I don’t use an Ubuntu based distro and I don’t use ppa repos, I’m limited in the help that I can offer. With this added information, I can verify that tomtomtom has not updated his ppa to support Ubuntu 21.04 or 21.10, and since you are trying to use Pop OS 21.10 based off of Ubuntu 21.10 that is creating the issue. So you could:

  1. Attempt compiling yourself conky-manager2 using the instructions on their github page. It would be a good learning experience for you.
  2. You could reach out to tomtomtom and ask if he would be willing to update that ppa to support 21.10. It looks like he has a ton of ppa repos that he maintains and he might have just let this one slip his notice. You can find contact info for tomtomtom on the ppa page here conky-manager : tomtomtom

Perhaps there is a 3rd option that you could manually write a “Release file” for the ppa and then it would install properly for Pop OS 21.10, but I’m not familiar enough with ppa’s to know if this is possible or not. Maybe someone more knowledgeable and familiar with Ubuntu and ppa’s could chime in and give you additional help.

I appreciate you taking the time to help. I will have a look at the GitHub page - as you say, it would be a learning experience, which is what I am striving for.

Thanks again.

1 Like