Change device boot order in VM on Proxmox

Hello all,
Still learning how to use Proxmox and ran into a new issue. My first VM is working fine. I just installed a new one and it works, but I can only boot if I hit escape to get to the Seabios boot menu and select the virtual hard drive. Otherwise, it attempts to boot by the CD-Rom followed by trying a PXE boot. Once both of those fail it reboots. If I use the menu and select the hard drive, it boots fine. I have been unable to find a way to change the boot device order. Can anyone advise how to do this? Thanks!

The boot order options should be in the options menu in the VM, did you already try setting the order there?

1 Like

Ah, dang it. Don’t know how I missed that. Thank you so much, Jay. Also, thank you for your excellent videos. You’ve helped me learn so much!

Awesome, I’m glad that worked for you.