Cannot boot from usb on a W7 + ZorinOS dual-boot

Hi everyone,

The issue as follows: I have a machine setup to dual boot with Windows 7 and ZorinOS. I’ve been meaning to try other distributions and created a bootable flash drive with PopOS using Balena Etcher. However the the USB is not recognized during boot process and cannot run it even to try it out.

After much back and forth these are some of the things I have already tried:

  1. Tried other USB ports in the machine.
  2. Tried other USB drives.
  3. Tried using another computer, where it does work as expected.
  4. Tried a different ISO file other than PopOS to confirm the ISO is not the issue.
  5. Tried using Rufus (from Windows 7) instead of Etcher, selecting MBR partition scheme.
  6. Tried using fdisk to manually modify the partition types on the bootable flash drive from “EFI (FAT-12/16/32)” to “W95 FAT32”
  7. Tried running boot-repair with the default recommended repair mode (Generated report)

Aside from the fact that I cannot boot from this flash drive, everything is working great. The fact that I can try out PopOS (and other distros) from another computer makes me think this is an issue with the BIOS or something related to the boot process. Unfortunately this is already far beyond my experience, does anyone have any ideas what this could be and how to fix it?

Any help is much appreciated!

Since the usb works in another machine I would start by investigating the bios configuration on the matching on which you want to Linux.

Is the bios recognizing that a USB is inserted into the machine during boot up or is it just booting straight to the windows without pausing?

If it is going straight into windows without pausing you will need to adjust the ‘boot order’ in bios. Entering the bios is a little different for every laptop. Just google “boot bios Lenovo p73” for your brand and model of laptop to get the correct process.

It is usually something like press F12 as fast as possible when you first turn the computer on. From there you can usually select a temporary boot device or go into the bios to set the boot order to make the USB drive first.

If I misunderstood the issue you are having, please let me know.

1 Like

I have the correct boot order in the BIOS, I forgot to mention that, and the USB is not recognized at all is just jumps straight into the GRUB loader screen where I can pick Windows or ZorinOS. Even in the boot menu by pressing F12 there i no option to use the external USB storage.

However I’ve just realized the BIOS is definitely the issue. I have been using Balena Etcher mostly and only tried Rufus once for PopOs, which allows me to set the flash drive partition scheme to MBR. However I just tried another two distros (Zorin Lite and Fedora) after flashing them from Rufus and they work fine.

So I’m suspecting that PopOS just doesn’t play well with older hardware, or perhaps I’m just unlucky with the hardware I’m currently using. Any change you (or someone else reading this) can confirm if PopOS works in older hardware? This one in particular is already 10 years old, though the specs are decent (i7, 8Gb RAM).

Either way, I think I’ll stick with Fedora for now since I’ve struggled for a couple of days already with this and I need to get some work done! :smile:

Thanks for the help!

I’ll try to find the video again, but, I think @Jay mentioned something about new v.s. older hardware and Pop_OS.

If I find it, I’ll post it back here.

1 Like

Found it: T = 4:30. There doesn’t’ seem to be a lot really. 64-bit CPU, UEFI, and minimal RAM / HD space. He also uses USB Imager to flash the USB device.

Pop_OS! - Full Beginners Guide

Yeah, I’ve read other posts from people using it in older hardware too so I’m not sure what can be the problem. I’m still curious so I will try and ask in the Pop-planet forums later and see if I can find out more. Thanks for the help!

Just to help foks dig around some on the issue, what’s the hardware specs on the target machine?

BIOS / Manufacturer / Version
Motherboard / Brand
Hard Drive / SSD / NVME
Whatever else you can dig up.

Not quite sure how to find out about the motherboard information but this is what I could find:

Brand/Model: Dell XPS L502X
BIOS: Dell Inc. A10
CPU: Intel Core i7-2640M CPU @ 2.80GHz x 4
Graphics: Nvidia GeForce GT 525M
Hard Drive: 500GB HDD

1 Like

That’s a good start. If folks want the MB info, they can go to Dell and look it up easy enough.

+1. If something works go with it until you have the time and patience to dig deeper.

If you want to dig deeper, the next things I would try would be to:

  1. See if you can update the bios.
  2. Play around with legacy, uefi, and efi bios modes.
  3. Play around with secure-boot mode.
  4. Look into GPT vs MBR partition methods.

Around 2010 was a rough time for bios. Microsoft was incentivizing hardware manufacturers not to allow alternate operating systems to run on their hardware… or at least make it difficult.

1 Like

Thank you for the tips! I’ve learned a lot these last few days as I continued tweaking my machine but I’m most definitely interested about updating the BIOS as I have another older machine that I would like to (eventually) setup in a similar way. I will look into that little roadmap :+1: