Ubuntu 22.04 and Kubernetes recently Broke Compatibility with Each Other (and how to work around it)

Originally published at: Ubuntu 22.04 and Kubernetes recently Broke Compatibility with Each Other (and how to work around it) – Learn Linux TV

Here’s another blog post today, that I’m creating for the same reason as the previous one. It took me a bit longer than I’d like to admit to figure this out, and if anyone else out there is wondering why their automated Kubernetes builds on Ubuntu 22.04 started failing on them suddenly for no apparent…

2 Likes

I was checking why I didn’t run into this issue, but I am using containerd.io from docker in stead of the ubuntu version. You can install it (as you are probably aware) via

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key --keyring /etc/apt/trusted.gpg.d/docker.gpg add -
sudo add-apt-repository "deb [arch=arm64] https://download.docker.com/linux/ubuntu focal stable"
sudo apt-get update && sudo apt-get install -y containerd.io

I had this installed with my original kubernetes installation from ubuntu 20.04, which I upgraded later to ubuntu 22.04.

2 Likes