Testing the new Arch Linux Guided Installer

Originally published at: Testing the new Arch Linux Guided Installer – LearnLinuxTV

@jay nice little video walk through of a useful tool, I didn’t know existed.

The only “Arch” install I have done was with Endeavour OS when it first released. I didn’t spend a lot of time in it because I don’t have strong reasons for wanting to run Arch on one of my Linux boxes.

My son who enjoys coding on Linux, mostly works on MX Linux, but has used Endeavour in the past to try out the latest and greatest development tools like code completion tools or the latest vim.

This Python script makes it almost as easy as Endeavour to get a vanilla Arch installed. I plan on sharing this with my developer son. Thanks for finding and demonstrating this tool on your channel.

I have tested the guided install for Arch Linux. It only works when you are on UEFI not on regular MBR.
Since my laptop does not have UEFI, it never work for me.

@jay Nice video presentation. I downloaded the Arch 2021.05.01 ISO, then booted up on a USB stick of the bootable OS using Balena Etcher, then ran the tty installer to install the system on a 120 GB external USB. I elected the KDE desktop. Everything installed as advertised and the system is running great.

Are the AUR helpers supported in Arch? I tried installing yay or paru tonight, but after cloning the github project for both and attempting to install, I can’t seem to get it to work and cannot install either. Any advice on how this is best accomplished.

I’m glad to see that Arch finally has a installer, albeit a tty installer. The last time I installed Arch from scratch, it took about 3 hours of tedious work.

I don’t want to go to the hard way of doing Arch Linux, so I install Manjaro KDE instead. A much easier way to do Arch Linux. It works with the AUR as well. I did install yay in Manjaro, and also I install Octopi. A Synaptic package manager type package installer for Arch Linux.

How old is your laptop? What model is it?

I don’t think the helpers are “supported” in terms of them being accepted by the community, but I’m not 100% sure if the community still has that stigma. I did a video a while back on setting up yay, which should still work today. I don’t remember off the top of my head which video that was, I think it was the pacman video if I’m not mistaken.

Thanks, @jay . I’ll search for it. I have installed yay and paru before in Arch, but wasn’t able to get it installed in this latest tty installer build.

@jay , the video that explains how to get yay was actually in your "Linux Essentials - The Arch User Repository (AUR) on YouTube. I followed the directions explicitly from your video making sure that I had the base-devel installed and already had git installed. When I cloned the repo for yay, changed into the yay directory, the PKGBUILD was the only directory showing. However, when I ran the makepkg -s command and hit Enter, I received the following error message:

==> ERROR: You do not have write permission for the directory $BUILDDIR (/home/datapioneer/yay).
Aborting…

So, I looked at the permissions on the PKGBUILD directory (assuming that the $BUILDDIR was pointing to that directory), I discovered the following:

-rw-r–r-- 1 root root 1.5K May 9 00:11 PKGBUILD

So, I see that my standard user does not have write permissions. I fixed this by running:

$ sudo chown -R datapioneer:root PKGBUILD

and the result was:

-rw-r–r-- 1 datapioneer root 1.5K May 9 00:11 PKGBUILD

When I reran the makepkg -s command once again, I got the same error. What am I doing wrong here. I can’t get paru installed either and receive the same error for paru that I received for yay. Would appreciate any help you can give me. Thanks.


My laptop is an NEC VersaPro Va-7 Core2Duo P8700 2.53 Ghz. laptop.
It has 6 gig of usable DDR3 SODIMM 1066 memories and had 2 Sandisk Ultra 128 Gb. SSD.
That is what I remember.

Hi, @jay Wanted to let you know that I discovered the problem with the error message received when attempting to install yay or paru. What I did was delete the paru directory, then cloned the paru repo without sudo. This fixed the permissions issue. After running makepkg -si paru and hitting Enter, all was well and paru is now installed. I could repeat this for yay, but I have paru and I believe that’s all that I will need. The whole purpose for getting paru is that I want to install the Brave web browser and this is not available in the Arch repos but is available in the AUR. Thanks, again.

Sorry I wasn’t able to get back to this topic quick enough. I was thinking that the permissions were wrong of the downloaded directory, but that should’ve solved it by itself. But I’m glad you got it working though.

Hi @jay , the permissions issue stemmed from the inherent ownership which occured when I used sudo to clone either paru or yay. When using sudo to perform this operation, as you know, the ownership and group ownership of the respective repos was root. This changes the permissions inherently based on ownership as my standard user would have no write privileges, hence the “write” error message being triggered. If, however, I dropped sudo when cloning either AUR helper, the ownership now becomes datapioneer:datapioneer for owner:group owner and the write privileges were attributed to datapioneer (my standard user) and the problem was averted.